Sage Business Cloud Financials - Partial Outage
Incident Report for Sage
Resolved
A third-party platform reported ‘Performance Degradation’ on a Sage system. The performance degradation lasted 17 minutes. The issue has been resolved and normal service has resumed.
Posted May 13, 2020 - 15:40 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 13, 2020 - 15:23 UTC
This incident affected: North America (Sage Business Cloud Financials).