Sage Business Cloud Payroll International - Degraded Performance
Incident Report for Sage
Resolved
The incident is now resolved. The service continues to perform as expected.
Posted Jul 29, 2024 - 09:55 UTC
Monitoring
We want to inform you that due to some banking issues in Canada, there has been a slight delay in processing the direct deposit payments that were scheduled for this morning. Please be assured that the issue is being addressed, and you should expect to see the payments reflected in your accounts by the end of the day.
Posted Jul 26, 2024 - 17:19 UTC
This incident affected: North America (Sage Business Cloud Payroll International).