Sage 50 / Sage 100 US Direct Deposit - Degraded Performance
Incident Report for Sage
Resolved
The incident is now resolved. Sage 50 /100 US Direct Deposit is available and performing as expected.
Posted Jan 10, 2022 - 21:13 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jan 10, 2022 - 20:49 UTC
This incident affected: North America (Sage 50 / Sage 100 US Direct Deposit).