Sage Construction Management - Partial Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Jun 12, 2024 - 15:01 UTC
Update
We are currently working on implementing the solution. Thank you for your patience as we work to resolve this issue.
Posted Jun 12, 2024 - 12:56 UTC
Update
We identified an issue in North America where a subset of customers are experiencing difficulty adding files while using the service. All other product functionality is working as expected.

We are currently investigating.
Posted Jun 11, 2024 - 14:12 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 11, 2024 - 13:54 UTC
This incident affected: North America (Sage Construction Management).