Sage RTX (EU) - RTX

Incident Report for Sage

Resolved

The issue is resolved and the affected services are available and performing as expected.
Posted Jul 30, 2026 - 16:14 UTC

Identified

We identified an issue with the Irish Revenue Online Service (ROS) preventing Irish customers from transacting with the Payroll Submission to Revenue (PSRs).

The products/services affected are:
- Sage RTX (EU)
- Sage Business Cloud Payroll

We are engaged with third-party, Revenue Online Service (ROS), waiting for updates.
Posted Jul 30, 2026 - 10:12 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 30, 2026 - 09:52 UTC
This incident affected: Europe (Sage Business Cloud Payroll, Sage RTX (EU)).