Sage Identity Service - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted May 22, 2025 - 09:30 UTC

Identified

A subset of customers in Portugal has reported issues when trying to access Sage One Portugal. Customers are presented with the following error message: "Something went wrong. Please wait a few minutes and try again."
Customers who are prompted to enrol in Multi-Factor Authentication (MFA) should complete the enrolment process and avoid attempting to skip this crucial step.
Posted May 21, 2025 - 10:17 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 21, 2025 - 10:14 UTC
This incident affected: Europe (Sage Identity Service, Sage One Portugal).