Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2025 - 03:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Thursday, December 11th, 2025, for 7 hours, between 03:00 UTC and 10:00 BST. (13:00 AEST and 20:00 AEST); (22:00 EST on December 10th and 05:00 EST on December 11th).
The service may be unavailable for a few munites during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance système importante le mercredi 10 décembre, 2025, pendant 7 heures, entre 22:00 EST et 05:00 EST, le 11 décembre.
Le service pourrait être indisponible pendant quelques minutes durant cette période planifiée.
Nous nous excusons pour les inconvénients que cela pourrait causer.
Merci. L'équipe Sage.
Posted Nov 25, 2025 - 08:59 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).