Instant Analysis - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Feb 23, 2026 - 14:38 UTC

Monitoring

We identified an issue where Sage 50 customers in the UK were presented with error message "apologies, an unexpected error occurred. Please try again or contact customer support" when trying to run queries. The service is now restored and performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Feb 23, 2026 - 11:22 UTC