The issue is resolved and the service continues to perform as expected.
Posted Nov 05, 2025 - 16:25 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Nov 03, 2025 - 15:43 UTC
Update
The invoices are appearing correctly in the invoice list. We’re continuing to investigate the delays in bank balance updates.
Thank you for your patience as we work to resolve this issue.
Posted Nov 03, 2025 - 13:44 UTC
Update
We have identified an issue impacting customers in the UK where newly created invoices are not immediately showing up in the invoice list. We are currently investigating.
Posted Nov 03, 2025 - 12:18 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Nov 03, 2025 - 12:06 UTC
This incident affected: Europe (Sage Business Cloud Accounting (UKI)).