Sage South Africa Customer Services Telephony - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Mar 10, 2026 - 10:58 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Mar 09, 2026 - 13:47 UTC

Investigating

We’re currently experiencing an issue with our telephone lines in South africa. Our teams are working to resolve this as a priority. Please use online support channels in the meantime.

Thank you for your patience.
Posted Mar 09, 2026 - 08:41 UTC