Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 25, 2026 - 17:00 UTC
Scheduled
Sage Connected Services will be undergoing maintenance on Wednesday, February 25th, 2026, for 15 minutes, between 19:00 SAST and 19:15 SAST.
During this scheduled time, the below services will be unavailable: -Sage Connected Services -Pastel Payroll -VIP Payroll -Sage50c Accounting -Sage Evolution International
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Feb 24, 2026 - 17:07 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Connected Services, Sage Evolution International).