The service is now restored. The service is currently performing as expected. We are closely monitoring the service throughout the weekend.
Posted Oct 11, 2025 - 03:19 UTC
Update
We continue actively working hard to restore the service as quickly and smoothly as possible.
We appreciate your patience as we work to resolve this issue.
Posted Oct 10, 2025 - 20:40 UTC
Update
Sage HR, including the Sage HR mobile app, is temporarily down for maintenance. Our team is working hard to restore the service as quickly and smoothly as possible.
Thank you for your patience as we work to resolve this issue.
Posted Oct 10, 2025 - 13:32 UTC
Identified
We have identified a global issue impacting a subset of customers related to incorrect permission settings in certain areas of the application.
The cause has been identified, and we are currently working on a fix to resolve the issue.
Posted Oct 10, 2025 - 11:32 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Oct 10, 2025 - 10:54 UTC
This incident affects: South America (Sage HR), Middle East and Africa (Sage HR), Asia Pacific (Sage HR), North America (Sage HR), and Europe (Sage HR).