Home
Availability
Incident History
x
Get the
Atom Feed
or
RSS Feed
.
Sage People - Partial Outage
Incident Report for
Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted
Mar
26
,
2024
-
17:06
UTC
Update
We are continuing to investigate the cause of the issue.
Posted
Mar
26
,
2024
-
14:51
UTC
Identified
We have identified an issue preventing a subset of customers globally from accessing the service.
We are currently investigating.
Posted
Mar
26
,
2024
-
12:47
UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted
Mar
26
,
2024
-
12:24
UTC
This incident affected: North America (Sage People) and Europe (Sage People).
×
Subscribe to Incident
Subscribe to updates for
Sage People - Partial Outage
via . You'll receive .