Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 23:00 UTC
Scheduled
Brightpearl Europe will be undergoing maintenance on Thursday, March 12th, 2026, for 1 hour, between 23:00 UTC and 00:00 UTC, on March 13th. (00:00 CET and 01:00 CET, on March 13th.).
During this scheduled maintenance the reports may run slower for a subset of customers.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Mar 06, 2026 - 14:29 UTC
This scheduled maintenance affected: Europe (Brightpearl).