Sage Business Cloud Accounting ZA
Incident Report for Sage
Resolved
The service is operating as expected. The team are continuing to monitor the stability and performance.
Posted Mar 31, 2021 - 07:21 UTC
Update
We are aware that some customers are having difficulty using the Sage Business Cloud Accounting Service at the moment. Our team is working on restoring the service as a priority.
Posted Mar 30, 2021 - 11:04 UTC
Investigating
We are currently investigating this issue.
Posted Mar 30, 2021 - 11:03 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Accounting ZA).