AutoEntry - StatemenRec

Incident Report for Sage

Resolved

We identified a global issue where customers experienced delays in document processing. The incident has now been resolved, and the service is performing as expected.
Posted Feb 19, 2025 - 23:09 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Feb 19, 2025 - 22:21 UTC
This incident affected: Europe (AutoEntry).