This issue is resolved. All services continue to perform as expected.
Posted Mar 05, 2026 - 11:39 UTC
Monitoring
The service is restored. We will continue to monitor closely.
Posted Mar 04, 2026 - 15:46 UTC
Investigating
We identified that customers in the UK are being presented with error message "HMRC are currently experiencing delays processing submissions, you can close the wizard and check again later" when making HMRC submissions.
The products/services impacted are: Sage 50 Payroll SBC Payroll UKI
We are engaged with third-party, HMRC, waiting for updates.
Posted Mar 03, 2026 - 12:06 UTC
This incident affected: Europe (Sage Business Cloud Payroll).