Sage Payroll Online Micropay AU - Major Outage
Incident Report for Sage
Resolved
Sage Payroll Online MicrOpay is now available.
Sage wishes to apologise for any inconvenience that you may have experienced.
Posted Aug 31, 2020 - 21:56 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 31, 2020 - 21:50 UTC
This incident affected: Asia Pacific (Sage Payroll Online MicrOpay).