Sage People Payroll - Partial Outage
Incident Report for Sage
Identified
We continue to investigate the issue with the SFTP connection between Sage People HCM and Sage People Payroll.

While we work on restoring the service to full automation, we need to manually complete a step to publish payslips for colleagues to view. To ensure this is done, please contact our Sage People Support Team via the Sage People Community by clicking here: Case Submission. One of our experts will support you with this process.

We apologise for any inconvenience this may have caused.
Posted Sep 19, 2024 - 09:13 UTC
Investigating
Due to issues with the recent maintenance on Sage People Payroll, the SFTP connection between Sage People HCM and Sage People Payroll is currently unavailable for customers in the UK. All other product functionality is working as expected.

If you are trying to release your payslips, please contact your local Customer Support team that will be able to help you. To contact them you can raise a case using this link.

We are currently investigating.
Posted Sep 09, 2024 - 09:25 UTC
This incident affects: Europe (Sage People Payroll).