Sage Construction Management - Partial Outage

Incident Report for Sage

Resolved

The issue is now resolved and the service is performing as expected.
Posted Jul 28, 2025 - 05:50 UTC

Update

We are continuing to investigate the cause of the issue. We appreciate your patience as we work to resolve this issue.
Posted Jul 26, 2025 - 16:58 UTC

Update

We are continuing to investigate the issue with the dashboard service. Thank you for your patience as we work to resolve this issue.
Posted Jul 26, 2025 - 00:08 UTC

Update

The reports service has been restored. We are continuing to investigate the dashboard service.
Thank you for your patience as we work to resolve this issue.
Posted Jul 25, 2025 - 22:12 UTC

Update

We are continuing to investigate the cause of the issue.
Posted Jul 25, 2025 - 20:00 UTC

Update

We have identified an issue preventing customers from running selected reports. We are currently investigating.
Posted Jul 25, 2025 - 17:58 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 25, 2025 - 17:37 UTC
This incident affected: North America (Sage Construction Management).