Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 18:00 UTC
Scheduled
Pension Data Exchange (UKI) will be undergoing maintenance on Wednesday, March 26th, 2025, for 3 hours and 30 minutes, between 18:00 UCT and 21:30 UCT.
The service will not be available for the below products when making submissions: Pension Data Exchange. Sage 50. Sage Business Cloud Payroll.
We apologise for any inconvenience this may cause.
Thank you. The Sage Team.
Posted Mar 25, 2025 - 08:20 UTC
This scheduled maintenance affected: Europe (Pension Data Exchange (UKI), Sage 50, Sage Business Cloud Payroll).