Sage Identity Service - Degraded Performance

Incident Report for Sage

Resolved

We identified an issue where a subset of customers globally were experiencing intermittent issues when attempting to log in to their products. The issue is now resolved and the service is available and performing as expected
Posted Jul 24, 2025 - 08:29 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 24, 2025 - 07:50 UTC
This incident affected: South America (Sage ID), Middle East and Africa (Sage ID), Asia Pacific (Sage ID), North America (Sage ID), and Europe (Sage ID).