The issue is resolved and the service is available and performing as expected.
Posted Apr 28, 2026 - 10:42 UTC
Update
We have identified that customers globally are unable to use forms in Developer Experience (https://developer.sage.com/). When customers click on submit on the forms nothing happens, no error message is displayed.
Posted Apr 28, 2026 - 08:32 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 28, 2026 - 08:19 UTC
This incident affected: South America (Developer Experience Community), North America (Developer Experience Community), Asia Pacific (Developer Experience Community), Middle East and Africa (Developer Experience Community), and Europe (Developer Experience Community).