Sage Business Cloud Payroll - Partial Outage

Incident Report for Sage

Update

We have identified the cause of the issue and are working on a fix. Thank you for your patience as we work to resolve this issue.
Posted Apr 10, 2026 - 16:02 UTC

Update

We are continuing to investigate the cause of the issue. We appreciate your patience as we work to resolve this issue.
Posted Apr 09, 2026 - 15:46 UTC

Update

We are continuing to investigate the issue. As a workaround, customers can manually submit directly on People’s Pension website.
We appreciate your patience as we work to resolve this issue.
Posted Apr 08, 2026 - 15:04 UTC

Update

We have identified an issue preventing customers in the UKI from submitting week 1 pensions. Customers are presented with “there was an internal error with this submission” error message. As a workaround, customers can manually submit directly on People’s Pension website.
We are currently investigating.
Posted Apr 07, 2026 - 13:15 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 07, 2026 - 13:02 UTC
This incident affects: Europe (Sage Business Cloud Payroll).