Sage Business Cloud Payroll International - Operational
Incident Report for Sage
Resolved
The incident is now resolved and the service continues to operate as expected.
Posted May 06, 2022 - 15:42 UTC
Monitoring
The service is now available and operating as expected. We are closely monitoring the service to avoid a reoccurrence.
Posted May 05, 2022 - 11:24 UTC
Update
We have identified performance degradation in the service affecting a small subset of customers from Canada. We are investigating the cause of the issue.
Posted May 05, 2022 - 09:28 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 05, 2022 - 09:04 UTC
This incident affected: North America (Sage Business Cloud Payroll International).