Sage Identity Service - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Apr 04, 2025 - 10:56 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Apr 03, 2025 - 09:58 UTC

Update

We are continuing to investigate the cause of the issue. We appreciate your patience as we work to resolve this issue.
Posted Apr 02, 2025 - 15:07 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 13:25 UTC

Update

We identified that a subset of customers in the UK are not receiving their MFA SMS resulting in them not being able to log into the products. We are currently investigating.

Products/services affected:
50 Accounts
50 Payroll
Sage Business Cloud Accounting (UKI)
Sage Business Cloud Payroll
Sage For Accountants
Sage HR
Posted Apr 02, 2025 - 13:21 UTC

Update

We identified that a subset of customers in the UK are not receiving their MFA SMS resulting in them not being able to log into the products. We are currently investigating.
Posted Apr 02, 2025 - 12:58 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 02, 2025 - 12:40 UTC
This incident affected: Europe (Sage Identity Service).