Sage Connect - Degraded Performance

Incident Report for Sage

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service. Customers who continue to experience issues should close and reopen their browser before logging in again.
Posted Sep 11, 2026 - 09:49 UTC

Update

We have identified an issue preventing some customers in France and North America from accessing the Collaboration Portal. Affected customers are presented with an "Unable to load the page" error message.

The products/services affected are:
Sage 50
Sage 100
Sage X3
Sage FRP 1000 (FR)
Batigest
Sage Business Cloud Bureau

We are currently investigating the issue. As a workaround, affected customers can clear their browser cache and cookies to restore connectivity.
Posted Sep 11, 2026 - 08:42 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 11, 2026 - 08:18 UTC
This incident affects: Europe (Sage 50, Sage Business Cloud Bureau (FR), Sage Connect, Sage FRP 1000 (FR)).