Sage Licensing Service (SLS) - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Oct 06, 2025 - 22:26 UTC

Investigating

We have identified an issue preventing new US customers from activating new installations of Sage 50 US and Sage 50 Cloud.

We are currently investigating.
Posted Oct 06, 2025 - 21:58 UTC
This incident affected: North America (Sage 50, Sage 50 Cloud, Sage Licensing Service (SLS)).