The issue is resolved and the service continues to perform as expected.
Posted Mar 03, 2026 - 13:41 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Mar 02, 2026 - 13:07 UTC
Update
We identified an issue where some customers in the UK are experiencing delays when accessing the service. A subset of customers are seeing a “Spaceman” error, while others who were able to access the service are experiencing general page loading delays. We are currently investigating.
Posted Mar 02, 2026 - 11:26 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 02, 2026 - 11:15 UTC
This incident affected: Europe (Sage Business Cloud Accounting (UKI)).