Sage People Payroll - Minor Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Aug 26, 2024 - 00:27 UTC
Investigating
We identified that customers globally will be experiencing style issues with the UI Sage People Payroll, which could lead to some options of the service being unreachable.

We are currently investigating.
Posted Aug 23, 2024 - 08:20 UTC
This incident affected: Europe (Sage People Payroll).