Sage Business Cloud Accounting (UK) - Degraded Performance
Incident Report for Sage
Resolved
The issue has been resolved. The service is now working as expected.
Posted May 04, 2021 - 18:27 UTC
Update
We continue to investigate the issue.
Posted May 04, 2021 - 17:00 UTC
Update
We have detected that users from UK are facing delays when searching new invoices. We are currently investigating.
Posted May 04, 2021 - 15:45 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 04, 2021 - 15:19 UTC
This incident affected: Europe (Sage Business Cloud Accounting (UKI)).