Sage Business Cloud Financials - Major Outage
Incident Report for Sage
Resolved
Salesforce has resolved the issue affecting EU26, customers can now log back into their application.
Posted Jun 23, 2020 - 06:59 UTC
Identified
Salesforce have identified the issue and continue to troubleshoot the issue, customers on EU26 are unable to use the application.
Posted Jun 23, 2020 - 05:22 UTC
Update
We are continuing to investigate the issue with Sage Financials customers on EU26 with the Salesforce Technology team.
Posted Jun 23, 2020 - 04:27 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 23, 2020 - 04:20 UTC
This incident affected: Europe (Sage Business Cloud Financials).