Sage Construction Management - Partial Outage

Incident Report for Sage

Update

We have identified an intermittent issue with log and detailed analytic reports. All other product functionalities such as word templates and financial dashboards are performing as expected.
We are currently investigating.
Posted Sep 17, 2026 - 16:18 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 17, 2026 - 15:55 UTC
This incident affects: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).