Sage RTX (EU) - RTX

Incident Report for Sage

Resolved

This issue is now resolved. All services continue to perform as expected.
Posted Aug 27, 2026 - 14:34 UTC

Identified

We identified an issue with the Irish Revenue Online Service (ROS) preventing Irish customers from transacting with the Payroll Submission to Revenue (PSRs).

The products/services affected are:
- Sage RTX (EU)
- SBC Payroll UK

We are engaged with third party, Revenue Online Service (ROS) to investigate and resolve the issue. We are waiting for updates.
Posted Aug 27, 2026 - 09:43 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 27, 2026 - 09:22 UTC
This incident affected: Europe (Sage RTX (EU)).