Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2023 - 02:30 UTC
Scheduled
Sage Intacct - Global will be undergoing maintenance on Saturday, September 16th 2023 for 3 hours between 02:30 UTC and 05:30 UTC.
The service will not be available during this scheduled time.
We apologize for any inconvenience this may cause.
Thank you.
The Sage Team
Posted Sep 12, 2023 - 09:54 UTC
This scheduled maintenance affected: Asia Pacific (Sage Intacct - Australia), Middle East and Africa (Sage Intacct - Europe/Africa), North America (Sage Intacct - Canada, Sage Intacct - US), and Europe (Sage Intacct - Europe/Africa).