Sage Business Cloud Payroll South Africa - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Sep 29, 2025 - 14:40 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Sep 29, 2025 - 11:07 UTC

Identified

We identified that new customers in South Africa are unable to sign up for the product.

The product is performing as expected for existing customers.

We are currently investigating.
Posted Sep 29, 2025 - 10:18 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 29, 2025 - 10:02 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Payroll South Africa).