Sage Business Cloud Accounting ZA - Degraded Performance
Incident Report for Sage
Resolved
As a result of continual improvement work, SBCA has been performing well since yesterday morning and this incident is now resolved. As we strive to provide the best customer experience possible we will not stop there and we will continue to work on additional enhancements.
Posted Mar 31, 2023 - 11:42 UTC
Update
We continue to identify and resolve places where performance is suboptimal to make some short term improvements. We will also keep working hard on the more permanent fix that will take us a few more days to fully test and implement. The team is working around the clock to permanently resolve the issue that has been impacting customers.
Posted Mar 29, 2023 - 08:31 UTC
Update
We are aware that some of our customers are experiencing intermittent degraded performance on their software today - we appreciate your patience while we continue to investigate and make the necessary improvements to enhance your experience.
Posted Mar 28, 2023 - 09:10 UTC
Update
While we continue to introduce numerous iterative improvements we are aware of periodic, short lived performance issues for some customers. We appreciate your patience as we work hard to enhance customer experience.
Posted Mar 27, 2023 - 06:23 UTC
Identified
We have identified an issue for South African customers that might experience small periods of degraded performance when using Sage Business Cloud Accounting South Africa. 

 
We are currently working on introducing some improvements to the product.
Posted Mar 24, 2023 - 09:24 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Accounting ZA).