Compliance Service - Major Outage
Incident Report for Sage
Resolved
We have opened this as a duplicate incident and it will be closed and run under the Cloudflare incident.
Posted Jun 21, 2022 - 06:56 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 21, 2022 - 06:44 UTC
This incident affected: Europe (Compliance Service).