All Online Services - Intermittent issues with 3rd party services - Major Outage
Incident Report for Sage
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 22:23 UTC
Investigating
We are currently investigating an issue that is affecting the majority of our online services. We are working with our 3rd party providers to find a resolution.
Posted Jul 17, 2020 - 21:52 UTC
This incident affected: All Online Services.