Sage Network App - Degraded Performance
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Apr 18, 2024 - 17:51 UTC
Update
We identified an issue affecting customers from Europe where "Most Recent Links Sent" view fails to filter when selecting more than one filter. We are currently investigating.
Posted Apr 18, 2024 - 13:45 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 18, 2024 - 13:28 UTC
This incident affected: Europe (Sage Network App).