Sage HandiTax Cloud - Operational
Incident Report for Sage
Resolved
The service is performing as expected.
Posted Aug 01, 2021 - 22:38 UTC
Identified
The issue has been identified and we are currently working on fix.
Posted Jul 30, 2021 - 03:30 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 30, 2021 - 03:20 UTC