Sage Business Cloud Accounting (UK) - Degraded Performance
Incident Report for Sage
Resolved
All transactions are processing normally.
Posted Sep 14, 2020 - 21:46 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 14, 2020 - 21:14 UTC
This incident affected: Europe (Sage Business Cloud Accounting (UKI)).