Sage Business Cloud Financials - Major Outage
Incident Report for Sage
Resolved
The Salesforce Technology team have resolved the issue affecting EU25, customers can now log back into their application.
Posted Jun 27, 2020 - 12:06 UTC
Update
Service disruption affecting EU25 affecting customers, the Salesforce technology team are troubleshooting the issue.
Posted Jun 27, 2020 - 10:59 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 27, 2020 - 10:46 UTC
This incident affected: Europe (Sage Business Cloud Financials).