Sage Intacct - Degraded Performance
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Apr 05, 2024 - 16:28 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 05, 2024 - 16:10 UTC
This incident affected: North America (Sage Intacct).