My Sage - Major Outage
Incident Report for Sage
Resolved
The issue is resolved and the service continues to perform as expected.
Posted Apr 03, 2024 - 13:01 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Apr 03, 2024 - 07:43 UTC
Investigating
We have identified that some customers are unable to log into the product and some others are experiencing performance issues.

We are currently investigating.
Posted Apr 03, 2024 - 06:13 UTC
This incident affected: Europe (My Sage).