The issue is now resolved. The services are currently performing as expected, and customers can now view or download documents.
Posted May 07, 2025 - 13:19 UTC
Update
We continue to work on fixing this issue. We apologise for any inconvenience this might cause.
Posted May 07, 2025 - 11:42 UTC
Update
We are currently working on a fix to resolve the issue.
Thank you for your patience as we work to resolve this issue.
Posted May 07, 2025 - 10:28 UTC
Identified
We identified an issue in the UK preventing customers from viewing or downloading documents. Customers are being displayed with 'An error has occurred" message when they attempt to view or download documents.
Posted May 07, 2025 - 10:11 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 07, 2025 - 09:45 UTC
This incident affected: Europe (Online Bureau (UKI), Sage 50 Payroll).